Phone System Down
Incident Report for Rundown Creator
Resolved
Our phone lines are now operational again.
Posted Oct 08, 2024 - 19:14 PDT
Identified
Our phone provider, OpenPhone, is currently experiencing an outage, and as a result, our phone lines are down. While that gets sorted out, please email us instead of calling. Our email address is support@rundowncreator.com.
Posted Oct 08, 2024 - 18:34 PDT
This incident affected: Phone system.