Email delays
Incident Report for Rundown Creator
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 20:55 PDT
Update
This issue has been resolved.
Posted Jul 17, 2024 - 20:54 PDT
Identified
Our mail hosting provider, Fastmail, is currently experiencing some technical issues, and as a result, emails to/from @rundowncreator.com email addresses may be delayed. For urgent matters, please call or text 310-907-8910.
Posted Jul 17, 2024 - 08:52 PDT
This incident affected: Email (@rundowncreator.com Email).