Email delays
Incident Report for Rundown Creator
Resolved
This issue has been resolved.
Posted Jul 24, 2024 - 09:13 PDT
Identified
Our email hosting provider, Fastmail, is currently experiencing some technical issues again, and as a result, emails to/from @rundowncreator.com email addresses may be delayed. For urgent matters, please call or text 310-907-8910. This is unrelated to the CrowdStrike issue.
Posted Jul 19, 2024 - 08:45 PDT
This incident affected: Email (@rundowncreator.com Email).